Status: Open
Status: Answered
Status: Closed
Status: Duplicate

DCOM Configuration issue accessing Metastorm from another machine.

0
Posted Mar 23 by Raghavendra Sulegaon.

Hi

I am trying to install Metastorm 7.6.4.9 on 2012 machine.

I have installed Process Engine, Designer and Administrative tools in one machine ( .abc ) and Web Extensions on another machine (.xyz). Both are 2012 machines

Metastorm Process engine is started successfully on .abc without any error. When i try to access through web, i get following error

"Retrieving the COM class factory for remote component with CLSID {EBAC9532-3094-11D4-9B1F-00C04F2A1F69} from machine .abc failed due to the following error: 80070005."

When i check the logs,

in machine .abc i see the following error

"The application-specific permission settings do not grant Remote Activation permission for the COM Server application with CLSID
{EBAC9532-3094-11D4-9B1F-00C04F2A1F69}
and APPID
{C4E0FA00-475D-11D4-85D6-00105AD8842F}
to the user NT AUTHORITY\ANONYMOUS LOGON SID (S-1-5-7) from address .xyz running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool."

in .xyz machine i see the following error,

"DCOM got error "2147942405" from the computer .abc when attempting to activate the server:
{EBAC9532-3094-11D4-9B1F-00C04F2A1F69}"

i guess its DCOM config issue with .abc (Process Engine) machine.

Can you please help me with this.

Thanks
Raghavendra Sulegaon

3 Answers

0
BEST ANSWER: As chosen by the author.

You are correct that the issue relates to DCOM permissions. The DCOM error code 80070005 = access denied.

Essentially the MBPM web extensions needs to run under an account which is allowed to talk to the MBPM engine.

It has been a while since I ran the MBPM v7 installation, but from memory it should be possible to nominate an account during MBPM installation (on both .abc and .xyz).

As an alternative, I believe the Admin Guide gives instructions on how the IIS Manager and Component Services apps can be used to reconfigure the web and engine.

Cheers,

Ed Barrett


0
BEST ANSWER: As chosen by the author.

Hi Ed

Thanks for your reply.

I have installed Metastorm on both servers using same account. and also added this account to Administrators group as well.
Since the error is with respect to Anonymous Logon, i gave all permissions (Remote logon, remote launch, local logon and local launch) but still it does not work.

Thanks
Raghavendra Sulegaon


0
BEST ANSWER: As chosen by the author.

Hi Raghavendra,

Thank you for your time.

Can you try following and see if this helps, please?

1) Open IIS

2) Select Application Pools > Check MetastormWebAppPool identity.

3) Now Open Component Services > Computers > My Computer > Right Click > Properties > Click on COM Security

4) Now add MetastormWebAppPool account you see under identity column to "Edit Defaults…" for "Access Permissions" and "Launch and Activation Permissions…"

5) Click Ok

6) Now in Component Services > Computers > My Computer > COM+ Applications > Expand Metastorm Process Engine COM+ Application

7) Under Roles > Client > Users > Right Click > New > User > Now add MetastormWebAppPool account you see under identity column here as well

8) Once you have done above, please reset IIS and restart Metastorm Process Engine service

9) Clear browser cache and browse Metastorm Web Client again to see if above resolve the issue.

Many thanks,
Hiren.


 You have subscribed and will receive email notifications of updates to this topic. To unsubscribe, uncheck the checkbox.

Statistics

Related categories

Your answer

To leave an answer, please sign in.