Status: Open
Status: Answered
Status: Closed
Status: Duplicate

AppWorks 16.3 - App status shows as Scheduled for very long time.

0
Posted Nov 27 by Mahesh Pinnamaneni.

We have a fresh install of AppWorks 16.3 and we deployed an App created in Process Suite 16.2.2 using Entity Modeling to Gateway. It shows as Scheduled but never changes the status. Here is the contents of log file:

2017-11-27 11:20:09,5742017-11-27T11:20:09,574 [http-nio-8080-exec-1] INFO types.auth.ExpiringSession - Failed to load the session token timeout setting (otag.token.maxage) from the database, attempting to seed a default value
2017-11-27 11:22:32,5602017-11-27T11:22:32,560 [http-nio-8080-exec-7] WARN impl.deployment.DeploymentPreparerImpl - Failed to read web.xml to resolve the app filter and bootstrap listener
2017-11-27 11:22:33,0912017-11-27T11:22:33,091 [http-nio-8080-exec-7] INFO service.impl.AppsBeanImpl - otag@otag uploaded a bundle named ConfigMgmtProductVersions_1.0.0.zip
2017-11-27 11:22:33,5542017-11-27T11:22:33,554 [http-nio-8080-exec-4] INFO monitor.impl.DeploymentMonitorImpl - Setting deployment state for ConfigMgmtProductVersions to SCHEDULED
2017-11-27 11:22:33,5852017-11-27T11:22:33,585 [http-nio-8080-exec-4] INFO deployment.monitor.DeploymentWatcherThread - Creating deployment watcher thread for app ConfigMgmtProductVersions - build job id 9bd845fc-5283-49b0-94e8-2f09fef8858b
2017-11-27 11:22:33,5852017-11-27T11:22:33,585 [DeploymentWatcher-OTAG-ConfigMgmtProductVersions-DEPLOYING-REDEPLOYER=false] INFO deployment.monitor.DeploymentWatcherThread - ===Started DeploymentWatcher-OTAG-ConfigMgmtProductVersions-DEPLOYING-REDEPLOYER=false running - DeploymentWatcher-OTAG-ConfigMgmtProductVersions-DEPLOYING-REDEPLOYER=false
DeploymentWatcherThread{
isDeployer=true
, created=Mon Nov 27 11:22:33 EST 2017
, transitionComplete=false
, appName='ConfigMgmtProductVersions'
, interval=10000
, permittedIterations=30
, monitoringActive=true
, permitRetry=false
, awaitingStart=true
, retryCount=0
, runCount=0
, deploymentState=SCHEDULED
, types=[app]
}
2017-11-27 11:22:33,6012017-11-27T11:22:33,601 [http-nio-8080-exec-4] INFO monitor.impl.DeploymentMonitorImpl - ===Scheduling deployment action request - DeploymentActionRequest{appName='ConfigMgmtProductVersions', action=DEPLOY, timestamp=1511799753601, isRestart=false}
2017-11-27 11:22:33,6012017-11-27T11:22:33,601 [http-nio-8080-exec-4] INFO monitor.impl.DeploymentSchedulerImpl - Received deployment request - DeploymentActionRequest{appName='ConfigMgmtProductVersions', action=DEPLOY, timestamp=1511799753601, isRestart=false}
2017-11-27 11:22:33,7102017-11-27T11:22:33,710 [http-nio-8080-exec-4] INFO service.impl.StagedAppsBeanImpl - ConfigMgmtProductVersions was installed by otag@otag, version 1.0.0
2017-11-27 11:25:05,0812017-11-27T11:25:05,081 [http-nio-8080-exec-10] INFO service.impl.SettingsBeanImpl - Setting ConfigMgmtProductVersions.releaseNumber updated with value 1.0.0 by admin with username otag@otag

Any help would be appreciated.
Thanks,
Mahesh

2 Answers

0
BEST ANSWER: As chosen by the author.

Hi

I have reached out to you directly via email to help with this issue

Regards

Simon


0
BEST ANSWER: As chosen by the author.

Issue was due to the use of Tomcat 8.5 which is not currently supported


 You have subscribed and will receive email notifications of updates to this topic. To unsubscribe, uncheck the checkbox.

Statistics

Related categories

Related tags

Your answer

To leave an answer, please sign in.