Status: Open
Status: Answered
Status: Closed
Status: Duplicate

Tempo Box - External users not receiving email notification

0
Posted Jan 04 by Harish Thunga.

Hi All,

We are trying to send invitation to external users to access the shared tempo box folders. While sharing , the email notification is not being sent to the external user however User has been created in the OTDS with proper userid and email address.

We have configured SMTP details in both the places (Appsgateway and Content server) . In order to verify the smtp details, we are able an invitation as email notification to a content server user.

Can you please guide me if I am missing any configuration to send an email notification to external user.

Thanks,
Harish Thunga

8 Answers

0
BEST ANSWER: As chosen by the author.

Hi

What version of Tempo and AppWorks are we looking at here ?

I would take a look at the otsync log file in the Content Server Logs directory to see if the post to the mail endpoint in appworks succeeds for a start

So as you say the external user is created in OTDS does it also get pushed to Content Server as a member of the external users group in CS ?

I would also recommend opening a ticket with opentext support as they will be able to assist you

Simon


0
BEST ANSWER: As chosen by the author.

I have the same problem.
Tempo Box Version 10.5.20
Content Server 10.5

@Harish, did you resolve the issue?


0
BEST ANSWER: As chosen by the author.

Have you checked with your SMTP team if the firewall is restricting email addresses with external domain? Try sending a test email to an external email address from your OTAG & Content server.


0
BEST ANSWER: As chosen by the author.

Hi there, not sure if you have resolved this or not, but the email notification will not go out until the user has been created in Content Server (kuaf table). Your "External" OTDS group needs to be added to you Content Server resource so the user is automatically created in Content Server.

This article may help: https://knowledge.opentext.com/knowledge/cs.dll/kcs/kbarticle/view/KB2655934

Cheers.
Patrick


1
BEST ANSWER: As chosen by the author.

I got my case solved. There was multiple possible causes.. so here is the checklist:

  1. check the certificates. All used root and intermediate certificates must be present in tomcat certificate store, Java installation cert store and Content Server java cert store.
  2. Check the CS side of Content Services setup. it should be filled automatically by Tempo installation, but for some reason it had failed. so check the key Content Service notifier settings - Shared key - the value from Appworks gateway Trusted Servers - OTSync server identifier; URIs - Tempo box URL with port number like "https://mytempo.something.whatever:443"; URI - this must be "http://tempoinvitehandler"
  3. Check the user partition for external users in OTDS - it MUST be dedicated partition just for this purpose only!
    check the password policy on the partition. Just for any case - avoid using spaces in the name of this partition, it may affect the behaviour, maybe not…

Hando


0
BEST ANSWER: As chosen by the author.

otcs 16.2.5
gateway 16.2.1
tempo bundle 16.1.2

i face the same problem (cant send external user invitation email)
record exist in [OTSyncPendingExtUsers] table
but not created in [NEWINVITEE]
already read this article https://knowledge.opentext.com/knowledge/cs.dll/kcs/kbarticle/view/KB2655934

anyone face / solved this issue ?

>otsync.log

09:04:01,040 [pool-1-thread-12] DEBUG org.apache.http.headers - >> POST /tempoInviteHandler/api/v1/invitations/create HTTP/1.1
09:04:01,040 [pool-1-thread-12] DEBUG org.apache.http.headers - >> content-type: application/x-www-form-urlencoded; charset=utf-8
09:04:01,040 [pool-1-thread-12] DEBUG org.apache.http.headers - >> Content-Length: 97
09:04:01,040 [pool-1-thread-12] DEBUG org.apache.http.headers - >> Host: dsrpot.app.co.id:18090
09:04:01,040 [pool-1-thread-12] DEBUG org.apache.http.headers - >> Connection: Keep-Alive
09:04:01,041 [pool-1-thread-12] DEBUG org.apache.http.wire - >> "key=7720d83b-a9e1-4c58-8231-84e45434cd18&email=betto_uajyxxx&password=aA1%21021507211422"
09:04:01,043 [pool-1-thread-12] DEBUG org.apache.http.wire - << "HTTP/1.1 404 Not Found[\r][\n]"
09:04:01,044 [pool-1-thread-12] DEBUG org.apache.http.wire - << "Server: Apache-Coyote/1.1[\r][\n]"
09:04:01,044 [pool-1-thread-12] DEBUG org.apache.http.wire - << "Content-Type: text/html;charset=utf-8[\r][\n]"
09:04:01,044 [pool-1-thread-12] DEBUG org.apache.http.wire - << "Content-Language: en[\r][\n]"
09:04:01,044 [pool-1-thread-12] DEBUG org.apache.http.wire - << "Content-Length: 992[\r][\n]"
09:04:01,045 [pool-1-thread-12] DEBUG org.apache.http.wire - << "Date: Fri, 07 Dec 2018 02:04:00 GMT[\r][\n]"
09:04:01,045 [pool-1-thread-12] DEBUG org.apache.http.wire - << "[\r][\n]"
>09:04:01,045 [pool-1-thread-12] DEBUG org.apache.http.impl.conn.DefaultClientConnection - Receiving response: HTTP/1.1 404 Not Found


0
BEST ANSWER: As chosen by the author.

Hi Alberto,
It looks like the Admin server cannot connect to the Tempo server (dsrpot.app.co.id:18090)
09:04:01,043 [pool-1-thread-12] DEBUG org.apache.http.wire - << "HTTP/1.1 404 Not Found[\r][\n]"

From your content servers (Front End / Admin) can you telnet to port 18090 on dsrpot.app.co.id ?


0
BEST ANSWER: As chosen by the author.

Hi Cameron Lyon.

Everything is on 1 server
i thing the problem is tempoInviteHandler apps

it is shown on tomcat/manager but i suspect the /api/v1/invitations/create not available

any idea why ?


 You have subscribed and will receive email notifications of updates to this topic. To unsubscribe, uncheck the checkbox.

Statistics

Related categories

Your answer

To leave an answer, please sign in.