Status: Open
Status: Answered
Status: Closed
Status: Duplicate

New validated and published entity not showing up in the 'Create a new item' list

0
Posted Dec 11 by Antal Bos.

Hi,

I installed a brand new image with Appworks 16.5 and as an unexperienced user started to play with it following the manual "Process Platform EntityModeling Guide"
At this moment I created a new workspace with 2 entities, validated them and installed them
After that I needed it to make it all security technical available to the users, but after this i get stuck.
What I can see in the front-end UI are my brand new lists for both my entities, but when I hit 'Create a new item' my entities are not available?

I already hit <Ctrl><F5>; cleaned the browser cache and even cleaned the TomEE cache, but still not available for my 'sysadmin' user. This last account is used for building the app and testing it.
Anyone with a suggestion what to do next?

Best regards,
Antal Bos

2 Answers

0
BEST ANSWER: As chosen by the author.

Hi Antal,

You have to make sure that the create forms are present with the name 'Create'.
Do you have that?


0
BEST ANSWER: As chosen by the author.

Hi Antal,
It may be a security issue.

When you create a new solution you need to both publish it and configure security settings to make it visible to end-users. (By default no permissions are granted). You need to set security grant at least "Use Solution" permissions to appropriate roles through the AppWorks Administrator interface.

If you refer to the online documentation in 16.5 you can find the instructions by navigating to
LOW-CODE DESIGN > Quick Start > Change security settings

The same instructions are available in the "AppWorks Platform 16.5 Low-Code Design Guide" starting on page 47.

After updating the security settings you will need to reload the solution UI page in your browser.


 You have subscribed and will receive email notifications of updates to this topic. To unsubscribe, uncheck the checkbox.

Statistics

Related categories

Your answer

To leave an answer, please sign in.