Status: Open
Status: Answered
Status: Closed
Status: Duplicate

Troubleshooting - Admin Tools Service Error

Posted May 07 by Daniel Michael.
Updated Jun 01.

This can be cause by a number of different things, from an engine that's not started to incorrect endpoints. Here is a general list of things to check


1) IIS Anonymous user settings

Often you'll see this error when someone has updated the password for the service account that is being used or if the service account was changed.

  1. open up iis manager (start > run > inetmgr)
  2. drill down to the MetastormAdministrationSvc virtual application
  3. click on authentication
  4. click on Anonymous Authentication
  5. On the right side under the 'actions' panel click edit
  6. Make sure that Anonymous user identity: is set to 'Specific user' and that it's set to your service account. For instance mine is running as dmichael702\metastorm


2) 7.6 Configuring IIS on Windows Server 2008 and Vista

You can find this in the Metastorm BPM 9.1 Web Client Configuration Guide.pdf

Users of Microsoft Windows Server 2008 in addition to the default settings will need IIS Metabase Compatibility to be installed and enabled on their systems before installing the Web features. The Anonymous authentication feature of IIS also needs to be enabled on the system in order for the Web Client and the Administrative Tools to be setup correctly. To enable anonymous authentication, perform the following steps:

  1. Open IIS.
  2. Select Metastorm Administration under Connection pane.
  3. Double-click Authentication icon in Features View.
  4. Enable Anonymous Authentication and click on Edit in Actions pane.
  5. Select Application pool identity option and click OK.
  6. Select Application pools in Connections pane.
  7. Select MetastormAdminAppPool in Feature View.
  8. Click on Advanced Settings in Actions pane.
  9. Click on Identity in Process Model and set the identity as domain user account.


3) Engine not running

This also happens if the engine is not running. Make sure the engine is started


4) Connection string

Verify that the connection string has the correct database and repository listed

C:\Program Files (x86)\Metastorm\BPM\Administrative Tools\Service\web.config

<add name="MetastormSQLConnectionString" connectionString="Data Source=DMICHAEL702;Initial Catalog=Metastorm;Persist Security Info=False;User ID=sa;Password=metastorm" providerName="System.Data.SqlClient"></add>
<add name="MetastormORAConnectionString" connectionString="DATA SOURCE=;PERSIST SECURITY INFO=False;USER ID=;Password=" providerName="Oracle.DataAccess.Client"></add>


5) Endpoints for the Admin Tools web.config

Check and make sure that the endpoints are set correctly. This shows which authentication engine to connect to and also which .svc to connect to.

C:\Program Files (x86)\Metastorm\BPM\Administrative Tools\Web\web.config

<endpoint address="net.tcp://DMICHAEL702:9000/engine/authentication" binding="netTcpBinding" bindingConfiguration="NetTcpBinding_IAuthenticationOperations" contract="MBPMAuthentication.IAuthenticationOperations" name="NetTcpBinding_IAuthenticationOperations">
<servicePrincipalName value=""></servicePrincipalName>
<endpoint address="<a data-ignore="a/b" target="_blank" href="http://localhost/MetastormAdministrationSvc/MBPMAdminService.svc">http://localhost/MetastormAdministrationSvc/MBPMAdminService.svc</a>" binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IMBPMAdminService" contract="MBPMAdmin.IMBPMAdminService" name="WSHttpBinding_IMBPMAdminService">
<dns value="localhost"></dns>


6) Split Web Client and Engine Consideration

Related to above, if Admin Tools are on a different server than the engine, point the Authentication endpoint to the engine server instead of to itself


7) Application Pool 32bit=true

On some systems when the MetastormAdminAppPool is set to 64bit bitness the site will fail to work. Check to see if 32bit = true for the admin application pool.

start > run > inetmgr > drill into application pools > right click MetastormAdminAppPool and select 'Advanced settings > change 'Enable 32-bit Application' to 'True'


 You have subscribed and will receive email notifications of updates to this topic. To unsubscribe, uncheck the checkbox.


Related categories

Your answer

To leave an answer, please sign in.