Status: Open
Status: Answered
Status: Closed
Status: Duplicate

form button aren't disabled in firefox

0
Posted Dec 12 by Michael Illarietti.

I have found a different behavior clicking form buttons using Internet Explorer and Firefox.

While using Internet Explorer once the button has been clicked, it became disabled, using Firefox it remains enabled.

Could you help me?

4 Answers

0
BEST ANSWER: As chosen by the author.

Perhaps this may help? (from the web client configuration guide pdf)-

 

6.1.8 Disable Field Access during Refill Requests
Default behavior related to refill requests is to allow for user editing of form fields during the request operation.
However, this can result in unexpected form field behavior following completion of the server request. To
address this issue, ShowRefillProgress application setting has been added to the Web Client
web.config file. This setting temporarily disables user access to form fields during the time that refill request
processing is being performed.
<add key="ShowRefillProgress="True"/>
A Refill progress icon displays during processing of the refill request and all fields on the form are locked out.


0
BEST ANSWER: As chosen by the author.

I tried to add this 

 

<add key="ShowRefillProgress" value="True"></add>

 

in Program Files (x86)\Metastorm\BPM\Web\we.config

 

<?xml version="1.0"?>
<configuration xmlns="<a data-ignore="a/b" target="_blank" href="http://schemas.microsoft.com/.NetConfiguration/v2.0">http://schemas.microsoft.com/.NetConfiguration/v2.0</a>">

<appSettings>

<add key="ShowRefillProgress" value="True"></add>

</appSettings>

 

it doesn't work .

I've done something wrong?


0
BEST ANSWER: As chosen by the author.

Just a sanity check - which version are you using?

 

This setting was introduced in versions 9.1.3 and above.

 

<appSettings>
  <!–Product Version updated by installation–>
  <add key="Product Version" value="9.2.0"></add>
  <add key="Version" value="9.2.0.956"></add>
  <add key="AppDescription" value="Web Build"></add>
  <add key="Auto Refresh Alert Lists" value="1"></add>
  <add key="Enable Public Attachment" value="0"></add>
  <add key="EnableReports" value="0"></add>
  <add key="OutputCacheTimeout" value="3600"></add>
  <!– Default value for rows per page in the ToDo/Watch/Blank/Admin/Report –>
  <add key="ListsPageSize" value="17"></add>
  <add key="DateFormat" value=""></add>
  <add key="TimeFormat" value=""></add>
  <add key="DecimalSeparator" value=""></add>
  <!– This setting is for development needs –>
  <add key="DisableScriptCombine" value="false"></add>
  <add key="ShowRefillProgress" value="true" />
  <!– Timeout in miliseconds for form operations such Refill, Submit, Cancel ect –>
  <add key="FormOperationsTimeout" value="0"></add>

 

Also if a script is very quick quick the refill progress won't stay on for long,

 

You can use a button with a System.Threading.Thread.Sleep(x) to test that it is working.

 

Kind Regards

 

Rich


0
BEST ANSWER: As chosen by the author.

I see that your "True" has an uppercase T…not sure if that matters, but if you look at all of the other tags, the "true" and "false" are all lowercase.

You should also do an IISRESET and restart your browser after making this change. I tested it yesterday before posting my response and it worked fine for me.


 You have subscribed and will receive email notifications of updates to this topic. To unsubscribe, uncheck the checkbox.

Statistics

Related categories

Your answer

To leave an answer, please sign in.