Status: Open
Status: Answered
Status: Closed
Status: Duplicate

Content Server via REST

Posted Dec 13 by Marimuthu D.

Do we have any documentation on usage of REST APIs of Content Server? What will be the base url to access the APIs. What are the requirements and configurations needed to enable this. Thanks

7 Answers

BEST ANSWER: As chosen by the author.

We don't have that yet; please see here:

BEST ANSWER: As chosen by the author.

+1 I'd like some examples/usage info also. Thanks.

BEST ANSWER: As chosen by the author.

If you are looking for Content Server APIs, I found this in developers API Reference.

This API reference has information about the URL routing and Operation Lists.

BEST ANSWER: As chosen by the author.

Were anyone able to use Livelink CS 10 REST API ? What is going to be base URL

BEST ANSWER: As chosen by the author.

I still can't connect to Content Server via REST.

I found this:
Its quite helpful, but doesn't contain an actual URL of a real server, so I can't validate that I'm using the right URL.

But every time I try to auth, I just get this response:
Content Server Error:&nbsp;Error dispatching request.
<P>[Required input argument &quot;func&quot; not specified.]</P>

My URL is http://myserver/MY_TEST/cs.exe/api/v1/auth
And I'm POSTing with username=xxxx;password=yyyyy in the Body, with Content-Type application/x-www-form-urlencoded

(But even without the body and the content type, I get the same error).

BEST ANSWER: As chosen by the author.

"Required input argument "func" not specified." feels like some misconfiguration. The REST API URL is mapped to the request handler &lt;cgi_url&gt;?func=ll.restapi&amp;apiVersion=1&amp;resource=... internally, but you are supposed to use the alias. Your API base URL is correct; it is &lt;cgi_url&gt;/api/v1 where the CGI URL is your http://myserver/MY_TEST/cs.exe.

You may find some help with the authentication by looking at another post here.

BEST ANSWER: As chosen by the author.

Hi Ferdinand, I agree - it was responding as if Update 13 wasn't applied (but it was, and it shows in CS). Thanks for the info on what looks right. I'll check that other thread too.

 You have subscribed and will receive email notifications of updates to this topic. To unsubscribe, uncheck the checkbox.


Related categories

Your answer

To leave an answer, please sign in.